#256 ✓invalid
Ahmet Simsek

Kete Installation problems.

Reported by Ahmet Simsek | February 18th, 2010 @ 06:31 AM

Dear Sir,

We had quite difficult time to install kete on Ubuntu keramic koala. I can't still run kete via Apache, I suspect the directives are not rigt, but half way through with the script/server command via WEBrick 1.3.1.

I had problems with mysql rake db:migrate command in the apps/kete directory. The production db has been crated but not the development db. We dumped the sql statements from production, changed the name to "development", created the development db. In this case we got the login screen of kete and succeed to run the configuration up to search engine, there it hung.

This was the situation 10 hours ago, when I quit from WEBrick and restart http://10.0.1.69:3000/

I copy the error :

ActiveRecord::StatementInvalid in Index pageController#index

Mysql::Error: Unknown column 'lft' in 'order clause': SELECT * FROM comments WHERE (title != 'Pending Moderation' AND commentable_private = 0) AND (comments.commentable_id = 13 AND comments.commentable_type = 'Topic') ORDER BY lft

I might clean databases and try to get the login screen but...

Any suggestion is welcome.

Thank you.

Comments and changes to this ticket

  • Ahmet Simsek

    Ahmet Simsek February 18th, 2010 @ 08:02 PM

    Excuse the prior cryptic info. More precisely what happens is: I finished the configuration screen of kete and it responded I should restart the server and run the background.rb (HOW??) When I start the server second time via scripts/server it crashed because of the sql statement ".. ORDER BY lft". The table 'comments' does not have a field named 'lft'. Maybe it's a parameter and must be evaluated to a field name??

    Please help.

  • Walter McGinnis

    Walter McGinnis February 19th, 2010 @ 03:16 PM

    Hi,

    Running Kete differs in certain regards from some other Ruby on Rails apps. For one thing, we don't support only using Webrick. The Kete Installation Guide (http://kete.net.nz/documentation/topics/show/114) is very specific and quite complete. If you throw in stuff from outside of the Kete Installation Guide (or skip steps), you will end up causing yourself trouble unless you ABSOLUTELY understand what you are doing.

    To me it sounds like you have installed things in quite a mish mash and stuff is in an inconstant state. I would recommend you start from the Installation Guide and make sure, step by step, you have followed it correctly.

    You might also consider asking for paid support from vendors listed on Kete.net.nz.

    Good luck and sorry I can't be of more help,
    Walter

  • Walter McGinnis

    Walter McGinnis January 6th, 2012 @ 11:44 AM

    • State changed from “new” to “invalid”
    • Milestone order changed from “0” to “0”

    Closing this as installing Kete 1.3, by the steps in the Installation Guide, now seems to work with later versions of Ubuntu (following the Debian directions).

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Kete was developed by Horowhenua Library Trust and Katipo Communications Ltd. to build a digital library of Horowhenua material.

People watching this ticket

Pages